Monitor Tests Forum

Full Version: Screen Blinking with AMD OC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Good day.

I've been having some problems with my monitor and the OC of my gpu. I own a RX 570 4GB and I overclocked it without problems(kinda). When I game and the gpu enters to stage 7 of the memory clock I can play without issues, but when I play some games that don't need a lot of gpu power (Hollow Knight, Hades, etc) I get random "blinks"(like the monitor is having problems with the refresh rate) or rarely, artifacts. I did some testing and this games stay between stage 0 and 3 of the memory Clock.
I haven't touched the Vram clocks, only the memories. I know that it's not a gpu problem since it can run perfectly my OC on the later stages, so I'm guessing is something between the configuration of my monitor and the drivers, but I can't figure out what.
I'm leaving some images of the config and the display settings, if anyone can help me figuring out if I should customize some of the specs of my monitor or if it's something else. Thanks in advance.

CPU: Ryzen 5 3600
RAM: 2x 8gb Crucial Ballistix 3200mhz
GPU: Gigabyte Rx 570 4gb Gaming
MONITOR: LG Flatron m2380a (Full hd lcd)

Display Settings (Amd Software):
Timing Info - Horizontal - Vertical
Total - 2080 - 1111
Display - 1920 - 1080
Front Porch - 48 - 1083
Sync Width - 32 - 5
Polarity - Positive - Negative

Interlaced/Progressive - Progressive
G.Pixel Clock (KHz) - 138660
G.Refresh Rate (Hz) - 60.0031
HDMI Link Status Monitoring - Enabled
Current Link Settings - Not Available
The problem has to be on the GPU's end. I bet the problem is happening when the memory clock changes, like it's not retraining the memory during the blanking periods fast enough. You could try increasing the resolution's vertical blanking/total to give it more time. Most monitors have the total at 1125 at 1080p. If that doesn't help, then the memory clock might be changing in the middle of a refresh when it's not supposed to. The problem would probably go away if you made the memory clock the same at all states, but then it wastes power at lower states. Another way to force the memory clock to never change is to reduce the resolution's vertical blanking/total low enough that the driver won't attempt to change the memory clock since it won't have enough time. Another possibility is maybe it needs more voltage at the lower states to be able to change to the higher states stably.
Thanks for the quick reply, Toasty. I changed the vertical blanking/total to 1125. The color scheme change and the text it's a lot more pixelated/choppy. I "fixed" that by reducing the sharpness of the monitor. Right now I'm testing to see if that fixed the blinking problem. In case it doesn't, you said that I could reduce the vertical blanking/total low enough, by how much?
That depends on the GPU. You'll have to play around and see. Probably 1100 or less.
Ok, a little update. increasing the vertical blanking/total didn't work. I reduced it to 1100 and for now haven't expirienced any blinking. Also I tested the states of the overclock and for sure the problem is between the state 1 and state 2.
I have a quick question about reducing the Vertical blanking/total. Now I have my Vram always at "full speed" (1750mhz). That's what yo meant by "won't attempt to change the memory clock"? I thought you were talking about the graphics memory and not the Vram.
I don't understand. The Vram clock is the graphics memory clock.
Sorry made a mess on my mind. I thought you were talking about the frequency and voltages of the gpu clock and not about the vram. So, to understand, you meant that the problem is when the gpu is trying to transition between memory states. Now I understand about keeping the 1750mhz of vram at all times. Too bad I can't play with the vram states when using amd adrenalin, to see if putting more voltage on the lower states, solves the problem.
Reference URL's