Post Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lost yCbCr 4:2:0 option
07-17-2016, 08:10 AM (This post was last modified: 07-18-2016 09:09 AM by gobblerjook.)
Post: #1
Lost yCbCr 4:2:0 option
Hi guys,

I've encountered a really weird problem using HDMI2.0 between my GTX 970 and my Sony XD93 UHD TV.

I had it working just fine, using 4k resolution, 60hz and the yCbCr 420 colour format. My TV accepted this as an "enhanced" 10 bit HDMI input. All good.

However, I then stupidly decided to try changing the colour format to yCbCr 444. My TV stopped recognising the signal completely and displayed nothing. After some research I've come to the conclusion that my TV will not do HDMI2.0 unless the 420 colour format is used.

The crazy problem I now have is that in the Nvidia control panel the option for yCbCr 420 has completely disappeared when I change the resolution of the TV. I can only select from RGB, yCbCr 444 and yCbCr 422. None of these work, I need to get back to the yCbCr 420 option.

I've tried a clean driver reinstall but this has not helped.

Does anyone have any ideas? I'm so annoyed that this was working fine and now I can't return to the previous setup I had... Is there any way that I can use CRU or similar application to force the correct colour format?

Thanks
Find all posts by this user
Quote this message in a reply
07-18-2016, 12:49 PM (This post was last modified: 07-18-2016 12:49 PM by gobblerjook.)
Post: #2
RE: Lost yCbCr 4:2:0 option
After searching round the site I managed to get things to work using the 2160p420-native.dat file, so I am now back to 4k at 60Hz and it automatically switched to 4:2:0.

Great!

The only problem I have now is that I can only select 8 bpc colour depth in my nvidia drivers. Previously I had 8 and 12 bit options (not sure why it wasn't 8 and 10 to be honest). I'd really like to be able to select 10 or 12 bit. Are there any tweaks I can make using CRU?

Smile
Find all posts by this user
Quote this message in a reply
07-20-2016, 04:42 AM
Post: #3
RE: Lost yCbCr 4:2:0 option
(07-17-2016 08:10 AM)gobblerjook Wrote:  However, I then stupidly decided to try changing the colour format to yCbCr 444. My TV stopped recognising the signal completely and displayed nothing. After some research I've come to the conclusion that my TV will not do HDMI2.0 unless the 420 colour format is used.
What did you do when you tried to change the color format to YCbCr 4:4:4? It shouldn't have been listed as an option in the NVIDIA control panel if the TV doesn't support it.


(07-18-2016 12:49 PM)gobblerjook Wrote:  After searching round the site I managed to get things to work using the 2160p420-native.dat file, so I am now back to 4k at 60Hz and it automatically switched to 4:2:0.
You shouldn't have to do this if the TV already defines YCbCr 4:2:0 resolutions in the EDID. If you used CRU, run reset-all.exe and reboot. If that doesn't restore the YCbCr 4:2:0 option, then try reinstalling the NVIDIA driver after using DDU: http://www.wagnardmobile.com/?q=display-...aller-ddu-


(07-18-2016 12:49 PM)gobblerjook Wrote:  The only problem I have now is that I can only select 8 bpc colour depth in my nvidia drivers. Previously I had 8 and 12 bit options (not sure why it wasn't 8 and 10 to be honest). I'd really like to be able to select 10 or 12 bit. Are there any tweaks I can make using CRU?
12-bit YCbCr 4:2:0 requires an HDMI 2.0 data block, but CRU doesn't have a way to add one yet. It's possible to import one, but you shouldn't have to use CRU to fix this in the first place.
Find all posts by this user
Quote this message in a reply
07-20-2016, 08:30 AM
Post: #4
RE: Lost yCbCr 4:2:0 option
(07-20-2016 04:42 AM)ToastyX Wrote:  
(07-17-2016 08:10 AM)gobblerjook Wrote:  However, I then stupidly decided to try changing the colour format to yCbCr 444. My TV stopped recognising the signal completely and displayed nothing. After some research I've come to the conclusion that my TV will not do HDMI2.0 unless the 420 colour format is used.
What did you do when you tried to change the color format to YCbCr 4:4:4? It shouldn't have been listed as an option in the NVIDIA control panel if the TV doesn't support it.


(07-18-2016 12:49 PM)gobblerjook Wrote:  After searching round the site I managed to get things to work using the 2160p420-native.dat file, so I am now back to 4k at 60Hz and it automatically switched to 4:2:0.
You shouldn't have to do this if the TV already defines YCbCr 4:2:0 resolutions in the EDID. If you used CRU, run reset-all.exe and reboot. If that doesn't restore the YCbCr 4:2:0 option, then try reinstalling the NVIDIA driver after using DDU: http://www.wagnardmobile.com/?q=display-...aller-ddu-


(07-18-2016 12:49 PM)gobblerjook Wrote:  The only problem I have now is that I can only select 8 bpc colour depth in my nvidia drivers. Previously I had 8 and 12 bit options (not sure why it wasn't 8 and 10 to be honest). I'd really like to be able to select 10 or 12 bit. Are there any tweaks I can make using CRU?
12-bit YCbCr 4:2:0 requires an HDMI 2.0 data block, but CRU doesn't have a way to add one yet. It's possible to import one, but you shouldn't have to use CRU to fix this in the first place.

Thanks Toasty.

My TV is a Sony XD93 and I've been discussing on the Sony support forum as well as AVforums. I have done a full reset with CRU and the 4:2:0 option has appeared now in my Nvidia Control Panel.

4:4:4 and 4:2:2 also appear and this is because the TV should support them. However, when I select them I get nothing. My current thinking is that this is due to my cable, which while supporting HDMI 2.0 18gbps, is 5m which may be too long. I'm looking at other options.

Thanks for your help.
Find all posts by this user
Quote this message in a reply
 Post Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)