Post Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
03-25-2019, 01:18 AM
Post: #1
Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
Hey all, I just got a new TV which I decided to hook up to my computer, and man is it giving me a lot of trouble I've never had before.

I managed to figure out most things by myself, using this forum as a guide, but I'm afraid I've just hit an impasse, and I need help.

Basically, I would like to use 4:2:0 over 4:2:2 (because multiple games exhibit worse banding in 4:2:2), but can't seem to do so. I'm using HDMI 2.0, so the best I can currently do is run at 4k60 HDR 4:2:2 10bit. The problem is that whenever I try to set the nvidia control panel to use 4:2:0, it reverts back to 4:2:2 immediately because I am missing the setting for 10bit in 4:2:0. If I set the bpc back to 8 bit, then I can change to 4:2:0 (and it sticks), but then I only get the choice of staying at 8bit, or going to 12bit (which is too much for the cable, and the screen turns purple).

Technically, it seems like it should be possible, but I can't figure it out. I found this forum, and the CRU utility, but I'm not afraid to say that I'm not understanding it fully at the moment.

Any ideas? All help is greatly appreciated.
Find all posts by this user
Quote this message in a reply
03-25-2019, 02:51 AM
Post: #2
RE: Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
In the extension block, the HDMI 2.0 data block has an option for YCbCr 4:2:0 30-bit (10 bpc). Make sure that's enabled.
Find all posts by this user
Quote this message in a reply
03-25-2019, 03:31 AM (This post was last modified: 03-25-2019 03:37 AM by nullsubject.)
Post: #3
RE: Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
Hey, thanks for the quick reply!

Assuming I'm following your instructions correctly, I believe this was already enabled.

[Image: QlE89blVUkM.jpg]

I've also just found this:

[Image: UKKPHBWpxy3.jpg]

...but it doesn't really sound like what you're describing (I may be misunderstanding).

[EDIT] Removed unnecessary quote.
Find all posts by this user
Quote this message in a reply
03-26-2019, 06:39 PM
Post: #4
RE: Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
Then YCbCr 4:2:0 10 bpc should be available. You'll have to ask NVIDIA why the driver is not allowing it.
Find all posts by this user
Quote this message in a reply
04-22-2019, 07:43 AM
Post: #5
RE: Forcing 4:2:0 over 4:2:2? Possible nvidia issue.
Ensure that you are using a Premium Certified HDMI Cable. They cost the same as any other cable, but using one completely eliminated issues I had similar to this.

Alternatively (and what I currently do) you could try using DSR to lessen bandwidth, effectively 'feigning' a high resolution but only using the bandwidth of a lower resolution.
Find all posts by this user
Quote this message in a reply
 Post Reply


Forum Jump:


User(s) browsing this thread: 1 Guest(s)